Description
When attempting to launch a fully managed Debezium CDC Source Connector in Confluent Cloud, output similar to the following is shown in the Confluent Cloud UI:
“The connection to the database could not be established. This may be a transient error and the connector will continue to retry, but if the error persists then please check the connector's database connection properties, and any connection/firewall settings to ensure the database is reachable.”
“The connection to the database timed out. This may be a transient error and the connector will continue to retry, but if the error persists then please check the connector's database connection properties, and any connection/firewall settings to ensure the database is reachable.”
Applies To
Fully Managed Debezium CDC Source Connectors (MySQL, SQL Server, PostgreSQL)
Confluent Cloud
Cause
The network connection between the fully managed connector and the database could not be established as expected.
Resolution
- Review the Manage Networking for Confluent Cloud Connectors to confirm if your network type (public, private link, peering/transit gateway) is supported in your specific configuration with respect to the type of connection (public or private) to the database.
- Confirm if the complete dynamic IP range used by a Cloud provider is allowed, as documented in this link: Egress IP address ranges .
- Review and follow the steps documented in Troubleshoot networking issues for fully managed connectors .