Description
The following error might be observed on the Confluent Cloud UI for Microsoft SQL Server Source/Sink Connectors:
"We are having some trouble connecting to your database. Please make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port."
“Connect timed out. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.“
Applies To
Confluent Cloud
Microsoft SQL Server Source Connector
Microsoft SQL Server Sink Connector
Cause
This error message indicates the connector is not able to connect to the specified SQL database instance.
Resolution
- Ensure that the Microsoft SQL Server is up and running and ready to accept the connections.
- If a firewall is enabled on the Microsoft SQL Server system level or at the Cloud provider level that is hosting the database, you will have to whitelist a set of IPs to allow connectivity. These IPs can differ based on the Confluent Cloud Network Type selected. Please review the documentation here and here to determine the IP address ranges to be whitelisted based on your environment.