Description
This article discusses how to handle the below user actionable error with a Fully managed Microsoft SQL Server Sink Connectors on Confluent Cloud
"Unable to login. Please check that the login exists and has the correct permissions."
Applies To
Microsoft SQL Server Sink Connector
Confluent Cloud
Cause
This issue occurs when the Database user does not have correct permission to access, User credentials are wrong or User does not exist.
Resolution
Ensure that the Database credentials are correct.
Also, verify if the User specified to access the database has the correct permissions.
Moreover, ensure that the user exists, where it is not deleted or deactivated.