Description
The following error might be observed on the Confluent Cloud UI for Oracle CDC Source connectors:
The connector failed because the redo log file <redo log file name> cannot be opened
Applies To
Confluent Cloud
Confluent Oracle CDC Source connector
Cause
This error message indicates that the connector is unable to access a specific redo log file because it has been deleted or is currently being used by another process, preventing the connector from reading the necessary data for replication or change data capture.
Resolution
- Verify the redo log files are stored on the database server and check if the specified file (<redo log file name>) exists. If the issue is due to missing log files from the Database server. We suggest following the recovery plan from the article here
- If the issue is identified that the file exists but still fails, we suggest checking with Oracle DBA or Oracle Support directly