Description
This article addresses signup and login failures with the error message "Invalid first or last name. It must not start with symbols." when attempting to access Confluent Cloud.
Applies To
- Confluent Cloud
- Security
Cause
The error message "Invalid first or last name. It must not start with symbols." is triggered when the identity data coming from identity provider / marketplace has an empty or symbol‑only first or last name (or one that starts with a symbol).
Confluent Cloud validates user profile fields during account creation and login. The validation requires:
- First name must not be empty
- Last name must not be empty
- Neither field can start with symbol characters (/, -, *, etc.)
When identity provider or marketplace account provides empty or symbol-prefixed name fields, Confluent Cloud rejects the user profile during authentication.
Resolution
To resolve this issue, valid user profile should be used in the IDP where the account is managed.
If User has no last name (single name)
Directory teams sometimes put a placeholder symbol (like .) as the last name. That will fail Confluent’s validation.
Example:
First name: Joe
Last name: . (a single dot as a placeholder)
This would result in "Invalid first or last name. It must not start with symbols." when tried to log into Confluent Cloud, because the last name effectively starts with a symbol and fails validation.
If User is an org admin try manually adding the user in Confluent Cloud.
When inviting/adding the user:
First name: a valid alphabetic name
Last name: a valid alphabetic name (it can match the first name if there is no last name)
If the error persists after fixing names.
Confirm the following in the identity/marketplace system:
Depending on how you access Confluent (direct, SSO, or Marketplace):
Same error may appear when the first or last name fields in Azure are empty or contains invalid characters (for example, starting with symbols).
Reach out to your Azure admin to check your user profile in Azure (AAD) to ensure both first and last names in the source system are non‑empty and do not start with symbols.
After updating those fields in Azure and waiting for sync(for Azure Marketplace, ~5 hours is a good rule of thumb). Confluent signup should be successful.