Description
This article provides insights into possible reasons why Consumer Lag details may not appear in the Confluent Cloud UI.
Applies To
Confluent Cloud
Consumer Lag
Cause
As part of our effort to improve the security posture and observability of the Confluent Cloud UI, the Consumer Lag UI is being adapted to use the Confluent Cloud Metrics API.
Resolution
The following UI elements may not be available anymore when using the Consumer Lag page within the Confluent Cloud Console (UI):
- Consumer offsets - as the Metrics API contains only the consumer lag
- Lag information for inactive consumer groups (consumer groups with no members)
- Lag information for consumers that use the
assign()method
Note that when Partition Assignor is stream, the consumer groups lag from Stream applications are displayed under the Kafka Stream section.
Reference: Monitor Consumer Lag via the Metrics API
Additional considerations are required due to some differences in the data between the Metrics API and the previous UI backend. See: Permissions required for Consumer Lag details on Confluent Cloud UI
Notes:
Consumer Lag UI details may take up to 5 minutes to update due to Metric Data Latency.
If the behavior is an inaccurate or incomplete Consumer Lag display in the UI such as:
- incorrect lag values (very large numbers or zeros);
- placeholder values such as
-999forcurrentOffset, this could occur when offset data is not yet available from the API; - missing topics, partitions, or consumer groups entirely
The would be due to limitation of the UI to render the data at scale. In this case, you would need to use the alternative tools such as Metrics API, CLI tools (e.g., kafka-consumer-groups), or Kafka Admin API to verify consumer group details and offsets information.
Reference: Monitor Offset Lag via Kafka Admin API